using-f-string-in-unsupported-version / W2601#

Message emitted:

F-strings are not supported by all versions included in the py-version setting

Description:

Used when the py-version set by the user is lower than 3.6 and pylint encounters a f-string.

Problematic code:

f"python {3.5} is past end of life"  # [using-f-string-in-unsupported-version]

Correct code:

"python {} is past end of life".format(3.5)

Additional details:

f-strings were introduced in Python version 3.6; to use them, please use a more recent version of Python.

Created by the unsupported_version checker.